Changes between Version 2 and Version 3 of rtos_arduino


Ignore:
Timestamp:
Nov 25, 2015, 11:03:02 AM (7 years ago)
Author:
ertl-honda
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • rtos_arduino

    v2 v3  
    11= TOPPERS/RCA(RTE/RTOS compatible with Arduino libraries) =
    22
     3== クイックスタート(GDBデバッグ版) ==
     4
     5=== 機材の用意 ===
     6* Windows PC (Makefileを整備すればMacでも動作するはず)
     7 * 64bitだと設定を変更しなくてもよいので楽
     8* Arduino M0 Pro
     9 * ''''!!Arduino M0 を買わないように注意!!''''
     10 * [https://www.switch-science.com/catalog/2299/ スイッチサイエンス],
     11 [http://akizukidenshi.com/catalog/g/gM-09392/ 秋月],
     12 [http://www.marutsu.co.jp/pc/i/544623/ マルツパーツ] 等で購入可能.
     13 
     14=== ツールのインストール ===
     15* [http://www.arduino.org/software Arduino IDE]のインストール.
     16 * .org版(1.7.x)をインストールすること.
     17 * インストーラに従ってインストールを実施する.
     18 
     19* Arduino IDE のインストールパスの設定
     20 * C:\Program Files (x86)\Arduino にインストールした場合は必要ない
     21 * インストールしたフォルダを以下のファイルに設定する
     22{{{
     23   ・example/do_path.bat
     24     SET ARDUINO_DIR=C:\Program Files (x86)\Arduino
     25   ・asp_1.9.1/target/arduino_m0_gcc/
     26     ARDUINO_BASE_DIR_WIN = C:\Program Files (x86)\Arduino
     27}}}
     28     
     29=== ビルド ===
     30* フォルダ ./example/basic を開く
     31* ./do_make.bat を実行
     32
     33=== 実行 ===
     34* ボードの''''PROGRAMポート''''とPCのUSBを接続する.
     35* Arduino IDEを起動する(teraterm等でも可)
     36 * ツール -> ポート -> COMx(Arduino M0 Pro (Programmmming Port)) を選択.
     37 * ツール -> シリアルモニタ を選択してシリアルモニタを実行する.
     38 * シリアルモニタの右下の速度を115200bpsに変更
     39* フォルダ ./example/basic を開く
     40  * ./do_run.bat を実行
     41 
     42=== デバッグ ===
     43* フォルダ ./example/basic を開く
     44* ./do_debug.bat を実行
     45 
     46=== クリーン ===
     47* フォルダ ./example/basic を開く
     48* ./do_clean.bat を実行
     49     
     50     
     51== クイックスタート(Atmel Studio使用版) ==
     52
     53=== ツールのインストール ====
     54* [http://www.atmel.com/ja/jp/tools/ATMELSTUDIO.aspx Atmel Studio] のインストール
     55 * インストーラに従ってインストールを実施する.
     56 
     57=== プロジェクトを開く ===
     58
     59* \example\basic\asp.atsln をタブルクリックするとAtmel Studioが起動する.
     60
     61=== ビルド ===
     62
     63* メニュー -> Build -> Build Solution を実行
     64
     65=== 実行 ===
     66
     67* メニュー -> Debug -> Start Debugging and Brake を実行
     68
     69メモリに書き込まれるため,実行を開始する.
     70ファイルメニューからrca_app.cpp を選択してブレークポイントを置くことが
     71可能.
     72
     73
     74== 注意点 ==
     75* Arduino IDEに含まれている M0 向けライブラリは開発されて日が浅いため
     76不具合やコンパイルが通らない場合があるため注意が必要.
     77 
    378== ライセンス ==
    479ファイル毎にライセンスが異なるので注意してください.
     
    984|| arduino_lib || それぞれのファイルに指定されたライセンス(GNU GPL or BSD) ||
    1085
    11 == クイックスタート ==