source: azure_iot_hub_f767zi/trunk/asp_baseplatform/lwip/contrib-2.1.0/ports/unix/check/Makefile@ 457

Last change on this file since 457 was 457, checked in by coas-nagasima, 4 years ago

ファイルを追加

File size: 3.1 KB
Line 
1#
2# Copyright (c) 2001, 2002 Swedish Institute of Computer Science.
3# All rights reserved.
4#
5# Redistribution and use in source and binary forms, with or without modification,
6# are permitted provided that the following conditions are met:
7#
8# 1. Redistributions of source code must retain the above copyright notice,
9# this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright notice,
11# this list of conditions and the following disclaimer in the documentation
12# and/or other materials provided with the distribution.
13# 3. The name of the author may not be used to endorse or promote products
14# derived from this software without specific prior written permission.
15#
16# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
17# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
18# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
19# SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
20# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
21# OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
22# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
23# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
24# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
25# OF SUCH DAMAGE.
26#
27# This file is part of the lwIP TCP/IP stack.
28#
29# Author: Adam Dunkels <adam@sics.se>
30#
31
32all compile: lwip_unittests
33.PHONY: all clean check
34
35# The include path to sys_arch.h and lwipopts.h must be first, so this must be before Common.mk
36CFLAGS=-DLWIP_NOASSERT_ON_ERROR -I/usr/include/check -I$(LWIPDIR)/../test/unit
37
38ifeq (clang,$(findstring clang,$(CC)))
39# check.h causes 'error: token pasting of ',' and __VA_ARGS__ is a GNU extension' with clang 9.0.0
40CFLAGS+=-Wno-gnu-zero-variadic-macro-arguments
41endif
42
43# Prevent compiling sys_arch.c of unix port because unit test provide their own port
44SYSARCH?=
45include ../Common.mk
46
47LDFLAGS:=-lcheck -lm $(LDFLAGS)
48
49ifneq ($(UNAME_S),Darwin)
50# check installed via brew on Darwin doesn't have a separate subunit library (must be statically linked)
51LDFLAGS+=-lsubunit
52endif
53
54TESTDIR=$(LWIPDIR)/../test/unit
55include $(TESTDIR)/Filelists.mk
56TESTOBJS=$(notdir $(TESTFILES:.c=.o))
57
58clean:
59 @rm -f *.o $(LWIPLIBCOMMON) $(APPLIB) lwip_unittests *.s .depend* *.core core lwip_unittests.xml
60
61depend dep: .depend
62
63include .depend
64
65.depend: $(LWIPFILES) $(APPFILES) $(TESTFILES)
66 $(CCDEP) $(CFLAGS) -MM $^ > .depend || rm -f .depend
67
68ifneq ($(UNAME_S),Darwin)
69# clang on Darwin doesn't support --start-group
70lwip_unittests: .depend $(TESTOBJS) $(LWIPLIBCOMMON) $(APPLIB)
71 $(CC) $(CFLAGS) -o lwip_unittests $(TESTOBJS) -Wl,--start-group $(LWIPLIBCOMMON) $(APPLIB) $(LDFLAGS) -Wl,--end-group
72else
73lwip_unittests: .depend $(TESTOBJS) $(LWIPLIBCOMMON) $(APPLIB)
74 $(CC) $(CFLAGS) -o lwip_unittests $(TESTOBJS) $(LWIPLIBCOMMON) $(APPLIB) $(LDFLAGS)
75endif
76
77check: lwip_unittests
78 @./lwip_unittests
Note: See TracBrowser for help on using the repository browser.