source: azure_iot_hub_f767zi/trunk/asp_baseplatform/lwip/contrib-2.1.0/ports/win32/example_app/Makefile@ 457

Last change on this file since 457 was 457, checked in by coas-nagasima, 4 years ago

ファイルを追加

File size: 2.3 KB
RevLine 
[457]1#
2# Copyright (c) 2001, 2002 Swedish Institute of Computer Science.
3# All rights reserved.
4#
5# Redistribution and use in source and binary forms, with or without modification,
6# are permitted provided that the following conditions are met:
7#
8# 1. Redistributions of source code must retain the above copyright notice,
9# this list of conditions and the following disclaimer.
10# 2. Redistributions in binary form must reproduce the above copyright notice,
11# this list of conditions and the following disclaimer in the documentation
12# and/or other materials provided with the distribution.
13# 3. The name of the author may not be used to endorse or promote products
14# derived from this software without specific prior written permission.
15#
16# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
17# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
18# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT
19# SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
20# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT
21# OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
22# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
23# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING
24# IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY
25# OF SUCH DAMAGE.
26#
27# This file is part of the lwIP TCP/IP stack.
28#
29# Author: Adam Dunkels <adam@sics.se>
30#
31
32all compile: example_app makefsdata
33.PHONY: all
34
35include ../Common.mk
36
37CFLAGS+=-I$(CONTRIBDIR)/examples/example_app
38
39MAKEFSDATAOBJS=$(notdir $(MAKEFSDATAFILES:.c=.o))
40
41clean:
42 cmd /c del /q *.o $(LWIPLIBCOMMON) $(APPLIB) test.exe *.s .depend* *.map
43
44depend dep: .depend
45
46include .depend
47
48.depend: $(CONTRIBDIR)/examples/example_app/test.c default_netif.c $(LWIPFILES) $(APPFILES) $(MAKEFSDATAFILES)
49 $(CCDEP) $(CFLAGS) -MM $^ > .depend || cmd /c del .depend
50
51example_app: .depend $(LWIPLIBCOMMON) $(APPLIB) default_netif.o test.o
52 $(CC) $(CFLAGS) -o example_app test.o default_netif.o -Wl,--start-group $(APPLIB) $(LWIPLIBCOMMON) -Wl,--end-group $(LDFLAGS) -Xlinker -Map=test.map
53
54makefsdata: .depend $(MAKEFSDATAOBJS)
55 $(CC) $(CFLAGS) -o makefsdata $(MAKEFSDATAOBJS)
Note: See TracBrowser for help on using the repository browser.